Searching for messages sent via relay

Home Forums Messaging Software Exchange 2007 / 2010 / 2013 Searching for messages sent via relay

Viewing 1 post (of 1 total)
  • Author
    Posts
  • Avatar
    thetsg
    Member
    #155471

    I am having an issue with users having troubles searching for messages in Outlook that were sent via a relay.

    I have a receive connector on my hub transport that allows a server (Automate) to send out an email from a certain mailbox. Automate does not actually authenticate as this mailbox user, it just populates the From: address with the email address of the mailbox.

    When I look at the headers of a relayed message and compare them to a message that wasn’t relayed, I notice that the message-ID formats are different, i.e….
    Message-ID:
    Message-ID:

    As an Exchange admin, when I search that mailbox’s Sent Items with Outlook, I can see all messages sent from the mailbox, either from Outlook or relayed through the hub transport server(Automate). As a regular user searching the same mailbox, with the exact same search parameters, I can only see the ones that were sent directly from the mailbox, not the relayed ones. This also holds true for the mailbox itself – if I login as the mailbox owner I cannot search for the messages that were sent via relay.

    Another thing…. any user that cannot search for the relayed messages(including the mailbox owner) can browse for them in the Sent Items.

    Any ideas on how I can allow the regular mailbox users to see the relayed messages in a search?

    As always, all replies are much appreciated!!

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.