failover on 2811 with 2 ISPs

Home Forums Networking Cisco Routers & Switches How-to failover on 2811 with 2 ISPs

Viewing 1 post (of 1 total)
  • Author
    Posts

  • Roman_k
    Member
    #159188

    Hi,

    I have a cisco 2811 router with 2 wan ethernet ports and 4 lan ethernet ports, 2 internet connections (1 is FTTC (vdsl) connection so I configured pppoe dialer and 2 is Virgin media connection to the VM router so its simple ethernet connection with static public ip address) , both connections works fine.

    I configured local network with NAT on FTTC connection (tried it on VM as well) and that workes fine as well.

    What I am trying to achive is use wan1 (fttc) connection by default for NAT and if it goes down – switch to wan2 automaticaly.

    Idealy I would need to have part of local network to be NATing to wan1 and, if wan1 goes down, failover to wan2 and other part of local network to NAT to wan2 and, if wan2 goes down, to failover to wan1.

    Router details: Version 12.4(13r)T

    Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(12), RELEASE SOFTWARE (fc1)

    System image file is “flash:c2800nm-advipservicesk9-mz.124-12.bin”

    I configured the router as in example below using route maps and track command and the issue is that dialer (wan1 fttc connection) goes down, it swithes over to wan2 and doesnt go back to wan1 (dialer), its just doesnt dial fttc connection.

    this is my config:



    interface FastEthernet0/0

    description FTTC

    no ip address

    ip nat outside

    ip virtual-reassembly

    duplex auto

    speed auto

    pppoe enable group global

    pppoe-client dial-pool-number 1

    !

    interface FastEthernet0/1

    description $ETH-WAN$

    ip address 94.174.*** 255.255.255.248

    ip nat outside

    ip virtual-reassembly

    duplex auto

    speed auto

    interface Dialer1

    ip address negotiated

    ip mtu 1492

    ip nat outside

    ip virtual-reassembly

    encapsulation ppp

    load-interval 30

    dialer pool 1

    dialer-group 1

    ppp authentication chap callin

    ppp chap hostname ***********@itp.4adsl.net

    ppp chap password 0 *****

    ppp ipcp dns request

    route-map VIRGIN permit 10

    match ip address 1

    match interface fast 0/1

    exit

    route-map ENTA permit 10

    match ip address 1

    match interface Dialer1

    exit

    ip nat inside source route-map VIRGIN interface FastEthernet 0/1 overload

    ip nat inside source route-map ENTA interface Dialer1 overload

    ip sla 100

    icmp-echo 4.2.2.2 source-interface Fastethernet0

    timeout 500

    frequency 3

    track 100 rtr 100 reachability

    delay down 10 up 20

    ip route 0.0.0.0 0.0.0.0 Dialer1 track 100

    ip route 0.0.0.0 0.0.0.0 FastEthernet 0/1 94.174.**** 10



    Any input would be appreciated

    Thanks

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.

External Sharing and Guest User Access in Microsoft 365 and Teams

This eBook will dive into policy considerations you need to make when creating and managing guest user access to your Teams network, as well as the different layers of guest access and the common challenges that accompany a more complicated Microsoft 365 infrastructure.

You will learn:

  • Who should be allowed to be invited as a guest?
  • What type of guests should be able to access files in SharePoint and OneDrive?
  • How should guests be offboarded?
  • How should you determine who has access to sensitive information in your environment?

Sponsored by: