Coming Soon: GET-IT: Endpoint Management 1-Day Conference on September 28th at 9:30 AM ET Coming Soon: GET-IT: Endpoint Management 1-Day Conference on September 28th at 9:30 AM ET

Weird behaviour with wireless adaptor

Home Forums Networking General Networking Weird behaviour with wireless adaptor


Viewing 1 post (of 1 total)
  • Author

  • Blood

    Hello, folks

    I had a very strange issue with a Belkin wireless adaptor on a Windows 10 laptop.

    I picked it up because Sophos Enterprise Console was unable to install AV on the laptop. The troubleshooting guide mentioned that it may be a DNS issue and that the records may not be up to date or mismatched (conflicting A records etc.). Also, the person that uses the laptop said they were unable to connect to the printer shared on the domain controller.

    There was no A record and although a PTR record existed, it was ancient and the IP was registered against another name.

    When I tested connectivity, I could not get the laptop to connect via \\servername, but it would connect via \\IP-Address

    IP config showed an address in the correct subnet but, instead of the domain name, it showed the name of the router, a FritxBox. Turns out the router’s DHCP had not been disabled. So, got that disabled, and released / renewed the IP address. This is where the weirdness began.

    When I configured IPv4 on the adaptor to use DHCP, instead of getting an address within it grabbed

    OK, so I assigned a static address But, running ipconfig exposed Choosing the option to validate settings on exit caused the network troubleshooter to start which applied a fix: to use DHCP.

    I tried all sorts. The address was (obviously), not being registered with DNS so there were no DNS records. The .20 address was available.

    In the end I plugged in a CAT cable the laptop sprang into life – correct domain reported in IPconfig, address correct, successful connection via \\servername.

    As luck would have it I was asked to look at this after I had finished my main task for being at this office and only had 30mins left until I had to leave, which meant I did not have time to pursue the problem further by updating the wireless adaptor’s driver.

    However, even if the wireless adaptor was out of date, would it have done this due to a driver issue? Also, all other wireless connections in the office worked fine – desktops, laptops, phones etc.

    Any thoughts?

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.

Live Webinar: Active Directory Security: What Needs Immediate Priority!Live on Tuesday, October 12th at 1 PM ET

Attacks on Active Directory are at an all-time high. Companies that are not taking heed are being punished, both monetarily and with loss of production.

In this webinar, you will learn:

  • How to prioritize vulnerability management
  • What attackers are leveraging to breach organizations
  • Where Active Directory security needs immediate attention
  • Overall strategy to secure your environment and keep it secured

Sponsored by: