Unable to mount PFDB. Unable to remove PFDB..

Home Forums Messaging Software Exchange 2007 / 2010 / 2013 Unable to mount PFDB. Unable to remove PFDB..

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #154681

    I have a client who has not been using public folders on their exchange 2007 DB. The folder is not set to mount and has not ever been mounted to my knowledge. I need to mount it now – and I get this:

    – A dialog box that says:

    At least one committed transaction log file is missing. Mounting this database will result in data loss. Do you want to continue?

    I do, I know there’s nothing in there. I get this when I click YES


    Microsoft Exchange Error


    Failed to mount database ‘Public Folder Database’.

    Public Folder Database
    Failed
    Error:
    Exchange is unable to mount the database that you specified. Specified database: HSA-SERVER-01Second Storage GroupPublic Folder Database; Error code: MapiExceptionJetErrorRequiredLogFilesMissing: Unable to mount database. (hr=0x80004005, ec=-543)
    .

    This is the file listing in the Second Storage Group folder which is in the default location on my SBS 2007 Server

    Volume in drive D is Data
    Volume Serial Number is 30C3-DA36

    Directory of D:Program FilesExchange ServerMailboxSecond Storage Group

    09/06/2010 09:36 AM

    .
    09/06/2010 09:36 AM
    ..
    09/06/2010 09:36 AM 8,192 E01.chk
    09/06/2010 09:35 AM 1,048,576 E01res00001.jrs
    09/06/2010 09:35 AM 1,048,576 E01res00002.jrs
    09/06/2010 09:35 AM
    IgnoredLogs
    09/06/2010 09:36 AM
    inspector
    08/02/2010 09:37 AM 56,639,488 Public Folder Database.edb
    4 File(s) 58,744,832 bytes
    4 Dir(s) 2,736,621,187,072 bytes free

    The file called E01.chk is a “recovered file fragments” file..

    So, it’s clear that somethings messed up here. I know I don’t need whatever’s left in there. I then tried to delete the database and I get this:(after addressing the Offline address book issue which I was able to deal with)


    Microsoft Exchange Error


    The public folder database ‘Public Folder Database’ cannot be deleted.

    Public Folder Database
    Failed
    Error:
    Exchange is unable to check the public folder replicas for “HSA-SERVER-01Second Storage GroupPublic Folder Database”. Verify the Microsoft Information Store service is running on HSA-SERVER-01.hsa.local, and that the database is properly mounted.

    MapiExceptionMdbOffline: Unable to determine if the store has local replicas (hr=0x80004005, ec=1142)

    So, then I thought about re-naming the Second Storage Group folder: I did that and nothing stopped me from doing that. I re-attempted removal after re-naming the file- and I got the same error.

    I seem to have a chicken-and-the-egg problem…

    Does anybody know what the right way to remove this database is so I can create a new one?

    Stats:
    Windows SBS 2008 SP2
    Exchange 2007 8.1
    AVG 9 (AVG did not have an exclusion set on Exchange so I added that- perhaps it explains the folder corruption)

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.