NAT & Unicast to Multicast Conversion

Home Forums Networking Cisco Routers & Switches How-to NAT & Unicast to Multicast Conversion

Viewing 1 post (of 1 total)
  • Author
    Posts
  • Avatar
    amit_singh
    Member
    #160872

    Dear all,
    I am trying to simulate two below scenarios, and finding some difficulties in implementation, and really need your support, please have a look if you can point out something.

    Scenario One:-

    I am planning to get the unicast streams from different 2-3 sources over internet, and I am doing NAT for port-forwarding all those unicast streams to a one private IP. Attached is the setup for your understanding.

    Setup: – Both unicast streams will be hitting to One Public IP (3.3.3.2) on UDP/TCP Port 1234, 1236 & 1238 only & the same ports need to be forwarded to natted One Private IP (10.10.10.4)

    My motive is to,
    1) NATTING these 2 unicast streams into one private IP(10.10.10.4) by checking Source & Destination based IP’s and ports, but in below configuration I cannot achieve on checking Source & Destination based IP’s and ports
    Router configuration:-

    interface GigabitEthernet0/0
    description ***Connected to Internet ***
    ip address 3.3.3.2 255.255.255.252
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat outside
    ip virtual-reassembly in
    load-interval 30
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/1
    description ***Connected to Cisco 2900 Switch***
    ip address 10.10.10.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    load-interval 30
    duplex auto
    speed auto
    !
    ip nat inside source static tcp 10.10.10.2 1234 3.3.3.2 1234 extendable
    ip nat inside source static udp 10.10.10.2 1234 3.3.3.2 1234 extendable
    ip nat inside source static tcp 10.10.10.2 1236 3.3.3.2 1236 extendable
    ip nat inside source static udp 10.10.10.2 1236 3.3.3.2 1236 extendable
    ip nat inside source static tcp 10.10.10.2 1238 3.3.3.2 1238 extendable
    ip nat inside source static udp 10.10.10.2 1238 3.3.3.2 1238 extendable

    Scenario Two:-

    I am planning to get the unicast streams from different 2-3 sources over internet, and I am doing NAT for converting these unicast streams into multicast streams. Attached is the setup for your understanding.

    Setup: – Both unicast streams will be hitting to One Public IP (3.3.3.2) on UDP/TCP Port 1234, 1236 & 1238 only & the same these 3 ports need to be forwarded on Natted these 2 multicast IPs 239.200.1.1 & 239.200.1.2

    My motive is to,
    1) Convert these 2 unicast streams by NATTING into 2 multicast unique streams using Source based IP’s and ports, but in below configuration I cannot achieve checking Source based IP’s and ports for converting to have 2 multicast IPs with same ports and cannot receive/join these multicast
    Router configuration:-

    ip multicast-routing
    !
    interface GigabitEthernet0/0
    description ***Connected to Internet ***
    ip address 3.3.3.2 255.255.255.252
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat outside
    ip pim sparse-mode
    ip virtual-reassembly in
    load-interval 30
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/1
    description ***Connected to Cisco 2900 Switch***
    ip address 10.10.10.1 255.255.255.0
    ip nat inside
    ip pim sparse-mode
    ip virtual-reassembly in
    load-interval 30
    duplex auto
    speed auto
    !
    interface Loopback0
    description ***RP for Multicast***
    ip address 10.10.40.1 255.255.255.255
    ip pim sparse-mode
    !
    ip pim rp-address 10.10.40.1
    !
    ip nat inside source static udp 239.200.1.1 1234 3.3.3.2 1234 extendable
    ip nat inside source static udp 239.200.1.1 1236 3.3.3.2 1236 extendable
    ip nat inside source static udp 239.200.1.1 1238 3.3.3.2 1238 extendable
    ip nat inside source static udp 239.200.1.2 1234 3.3.3.2 1234 extendable
    ip nat inside source static udp 239.200.1.2 1236 3.3.3.2 1236 extendable
    ip nat inside source static udp 239.200.1.2 1238 3.3.3.2 1238 extendable

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.