JCB.dll not found

Home Forums Messaging Software Exchange 2000 / 2003 JCB.dll not found

Viewing 1 post (of 1 total)
  • Author
  • Avatar

    Exchange 2003 corrupted database issue:

    I have a Dell Power Edge 1850 (2.8 GHz Proc 2 GB RAM a mirror raid for OS & Log files and a mirror raid 146GB for Exchange 2003 standard Mailbox database)
    My raid array on the database partition failed, after replacing the raid controller and rebuilding the Raid with new drives I rescued the edb file from one of the old drives and placed it on the new raid using the same folder structure as before. When attempting to mount the database it fails to mount saying the .edb is corrupt. Normally I would restore from a backup but my backups have failed to capture Exchange data for several weeks now due to a remote agent error with Symantec Backup Exec 2012. So I do not have a good backup to restore from.

    I need to rescue this database, but it is proving difficult. I run eseutil /mh to check the database condition and it reports it is in Dirty shutdown and it requires about 15 log files to be played into the store. So I run eseutil /ml and it reports the log files are there and are in good health so I run eseutil /r and replay the logs into the database, this completes successfully – yay me! SO I check the shutdown state again, but it still reports “dirty shutdown”. I then run eseutil /p on the database and it runs along fine, but then fails reporting an error that “jcb.dll” is missing and to copy the file over and click OK to try again. I copy the file (as well as ese.dll, exchmem.dll and exosal.dll) and click OK, but it does not continue, just returns the same error and it does not clear. In order to get out of the loop I have to close the command prompt. Results are still a dirty shutdown.

    I can’t run eseutil /d against it due to the shutdown state nor can I run it with the /g switch to check consistency.

    I need to rescue this database, even with some data loss it would be better than restoring from a very old, questionable backup. How can I get this database to mount?

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.