Coming Soon: GET-IT: Endpoint Management 1-Day Conference on September 28th at 9:30 AM ET Coming Soon: GET-IT: Endpoint Management 1-Day Conference on September 28th at 9:30 AM ET

Error connecting to RDS

Home Forums Server Operating Systems Windows Server 2016 Error connecting to RDS

Viewing 1 post (of 1 total)
  • Author

  • spanjokus

    Good afternoon, colleagues! For the third week now I have been struggling with an error on a new RDS farm. Created a new HA RDS farm based on Windows Server 2016, updated everything. When I try to connect using the short terminal, I get the error:

    “The connection cannot be completed because the remote computer that was reached is not the one you specified. This could be caused by an outdated entry in the DNS cache. Try using the IP address of the computer instead of the name.”

    I have already encountered this error earlier and solved it using one of the methods described in the article. But nothing helped, I will describe the infrastructure in more detail and what I did.

    There is a Vmware ESXI 6.5 cluster on physical Dell R740 servers. The entire RDS farm consists of virtual servers.

    * I checked that virtual machines do not take time from the iron server, this is disabled in VMware Tools
    * I have verified that the time on the domain controller exactly matches the time on the servers
    * I tried to clear the DNS cache everywhere, both on the DNS zone and the local cache
    * Checked with the dig utility that the request was going to the DNS server correctly
    * PTR records are available for the given login on RDS
    * Enabled logging on the DNS server and saw from the logs that the name was correctly resolved
    * Tried Linux utilities to make a DNS trace, the request goes to the desired DNS cluster
    * On the DNS server itself, the name is resolved correctly, but the short name also gives the same error

    If I try to access the FQDN of the name, then I am calmly allowed to the RDS farm, and by IP as well. Another interesting fact is that if I connect a VPN connection to the local network, and try to log in by a short name, then everything works and the error is only within the internal local network, which can still be checked and diagnosed. The nslookup utility resolves both ip and dns name correctly. Any help would be welcome.

    It is also interesting if I just take this short name and send it to DNS on any computer, then the error pops up the same, apparently somewhere there is some old value.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.

Live Webinar: Active Directory Security: What Needs Immediate Priority!Live on Tuesday, October 12th at 1 PM ET

Attacks on Active Directory are at an all-time high. Companies that are not taking heed are being punished, both monetarily and with loss of production.

In this webinar, you will learn:

  • How to prioritize vulnerability management
  • What attackers are leveraging to breach organizations
  • Where Active Directory security needs immediate attention
  • Overall strategy to secure your environment and keep it secured

Sponsored by: