Cisco 2600 IOS 12.3 outside interface and DHCP

Home Forums Networking Cisco Routers & Switches How-to Cisco 2600 IOS 12.3 outside interface and DHCP

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #125021

    I’ve got a 2621 router with Version 12.3(9e) of the IOS on there. I’ve been able to get the INSIDE interface to hand out DHCP addresses and even routed successfully inside with multiple subnets over multiple VLANS (I’ve got a 2924 switch, too, but that’s not the topic of this post), but the sticking point I’m seeing is getting the OUTSIDE interface to get an IP address via DHCP. Right now its just getting the address from my linksys router, so it’s all technically inside, but I’m acting like its inside/outside for lab and testing.

    So admittedly, I’m still learning access-list and access-group commands, but thats beyond my issue here. The router will get ONE DHCP address, keep it for the lease of 24 hours (via the linksys) and then DROP the address. I have to completely reboot the linksys and the router for it to renew the lease.

    WHY is this happening? Do I need to write an access list for DHCP requests ports 67 and 68 on the outside interface? (the full syntax of which escapes me at the moment)

    Also, here’s my config copy/pasted. fa0/1 is up/down cuz the switch was off at the time of playing with this. fa0/0 is the problem child here. ;-)

    Thanks in advance for any insight you all may provide!

    Current configuration : 1232 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname RichRouter
    !
    boot-start-marker
    boot-end-marker
    !
    no logging on
    enable secret 5 $1$uHc.$rDMSUqN6vtWsjsV9Z7tm30
    enable password
    !
    no aaa new-model
    ip subnet-zero
    ip cef
    !
    !
    !
    ip dhcp pool vlan1
    network 192.168.2.0 255.255.255.0
    default-router 192.168.2.1
    !
    ip audit po max-events 100
    ip dhcp-server 192.168.2.1
    no ftp-server write-enable
    !
    interface FastEthernet0/0
    ip address dhcp
    ip nat outside
    duplex auto
    speed auto
    !
    interface Serial0/0
    no ip address
    shutdown
    !
    interface FastEthernet0/1
    ip address 192.168.2.1 255.255.255.0
    ip nat inside
    duplex auto
    speed auto
    !
    router rip
    network 192.168.2.0
    network 0.0.0.0
    !
    ip http server
    ip classless
    !
    !
    banner motd ^C
    WARNING!!

    This system is intended for private use. Your connection
    to this system implies no expectation of privacy.
    Unauthorized connections and/or usage of this system
    is illegal. Upon detection, information will be
    collected and sent to the appropriate authorities.

    ^C
    !
    line con 0
    password
    login
    line aux 0
    line vty 0 4
    password

    login
    line vty 5 15
    password

    login
    !
    !
    end

    RichRouter#
    RichRouter#sh ip int brie
    Interface IP-Address OK? Method Status Prot
    ocol
    FastEthernet0/0 unassigned YES DHCP up up

    Serial0/0 unassigned YES NVRAM administratively down down

    FastEthernet0/1 192.168.2.1 YES NVRAM up down

    RichRouter#
    RichRouter#

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.