Autodiscover, Out of Office and Wildcard SSL

Home Forums Messaging Software Exchange 2007 / 2010 / 2013 Autodiscover, Out of Office and Wildcard SSL

Viewing 1 post (of 1 total)
  • Author
    Posts
  • Avatar
    Anonymous
    Guest
    #154284

    Background:

    Our Exchange 2010 server uses a wildcard SSL certificate
    *.PublicDomain.com

    The exchange server has CAS, Hub Transport and Mailbox roles.

    The exchange server is installed on a resource domain
    mailserver.mail.local

    The mailboxes are Linked Mailboxes, with LinkedMasterAccount set to their windows logon account within a trusted domain
    LogonDomainSome.Guy

    Outlook clients have been manually configured, pointing to the mail server via internal FQDN:
    mailserver.mail.local

    Issue:

    When trying to get into Out of Office settings in Outlook, the following error is displayed:
    “Your Out of Office settings cannot be displayed, because the server is currently unavailable. Try again later”

    Troubleshooting:

    Everything seems to point to Autodiscover not being set up correctly and OOF relying on this service.

    This sounded right, seeing as I hadn’t done any work on Autodiscover and all client workstations were configured manually.

    Changes made:

    I’ve now set up an A record on our public DNS to try and get Autodiscover and OOF working.

    A record:
    autodiscover.publicdomain.com -> public IP address for Exchange server

    I set up an A record on our internal DNS:
    autodiscover.publicdomain.com -> internal IP address for Exchange Server

    Result:

    Test exchange connectivity says Autodiscover is OK

    Out of Office error remains unchanged.

    All client PC’s are throwing an SSL security alert because mailserver.mail.local has a security certificate which does not match the name on certificate.
    (*.publicdomain.com)

    I’m out of my depth on this and have a lot of people angry at me

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.