
Last Update: Sep 24, 2024
This article is a non-direct continuation of the “What is a Public Key Infrastructure (PKI)?” found on the Petri IT Knowledgebase. Public-Key Cryptography and One-Way Functions As written in previous articles, Public-Key cryptography (as opposed to symmetric key cryptography) relies on one-way functions, which are functions that are easy to calculate but hard to invert…

The Internet Protocol version 4 (IPv4) (RFC791) there is a field, called "Protocol", to identify the next level protocol. This is an 8 bit field. In Internet Protocol version 6 (IPv6) (RFC1883 and RFC2460) this field is called the "Next Header" field. Protocol Numbers 0 HOPOPT IPv6 Hop-by-Hop Option 1 ICMP Internet Control Message 2…

Last Update: Dec 03, 2024
One of the major headaches when dealing with Active Directory is the issues of accidental deletion of objects by un-trained or malicious people. Of course one must have the right permissions in Active Directory in order to be able to delete any object from it, but this does happen now and then. For example, you…

Last Update: Sep 17, 2024
Microsoft’s newest operating system, Windows Server 2008, has only been released for a few weeks. The new OS features a new version of IIS, Server Core, Virtualization, Security, and all new Management features. Train Signal has released a 6+ hour course on DVD and is currently giving this away for free with any order. The…

Last Update: Nov 19, 2024
Problems in Synchronizing a Pocket PC with Exchange Server 2003 when using SSL and Forms-Based Authentication in OWA As written in my other article (How to Synchronize a Pocket PC with Exchange 2003?), Exchange Server 2003 has many new features tailored for mobile users. One of them is ActiveSync which can be used to establish…

Last Update: Nov 19, 2024
Windows 2000/XP/2003 added the ability to cache DNS lookup results in the client’s cache. This cache can be viewed by typing ipconfig /displaydns in the command prompt: Windows IP Configuration ddlnetwork.net —————————————- Record Name . . . . . : ddlnetwork.net Record Type . . . . . : 1 Time To Live . ….

Last Update: Sep 24, 2024
As I discussed in my previous article – “Share Calendars with Local Users using Internet Publishing“, Outlook 2007 has improved calendar sharing using Office Online. You can share your calendar with everyone, or with only designated people, by publishing your Internet Calendars to Office Online. You can publish and share your calendars with others by…

Last Update: Sep 17, 2024
How can I pre-configure the default language for the folder names inside my mailbox? If you use Microsoft Outlook Web Access to log on to a mailbox for the very first time, the following folders are always created in English: Calendar Journal Tasks Notes Contacts Only the standard Messaging Application Programming Interface (MAPI) folders are…

PowerPoint: Adding an Office Object to a Presentation Office allows referencing another Office application within a document as an icon (see Office: Adding another Document to an Office Document as an Icon) and clicking on it to open. However, when trying to implement this option within a presentation, the next slide is displayed. That is…

Last Update: Dec 03, 2024
What TCP and UDP ports does my Exchange 2000/2003 Server use? For purposes of configuring firewalls or for troubleshooting communications issues, it may be useful to know what TCP/UDP ports Exchange 2000 Server and Exchange 2000 Conferencing Server are using. This article is also true for Exchange Server 2003 installations. Protocol: LDAP Port (TCP/UDP): 389…