close

Don't miss out on our next GET-IT conference about Virtual Desktop Infrastructure!

Home

365 Apps

Microsoft 365 Changelog

M365 Changelog: We’ve changed the minimum iOS system requirements for Outlook for iOS and watchOS

Rabia Noureen

|

MC411432 – Outlook for iOS is supported on the two most recent versions of iOS. When a new version of iOS is released, Outlook’s Operating System requirement becomes the two most recent versions: the current version of iOS and watchOS and the previous version.

With iOS 16 currently in beta, Outlook for iOS is preparing to drop support for iOS 14. In addition, once iOS 16 is released to GA, the system requirements for Outlook for iOS will be updated to reflect support for iOS 16. Microsoft will update the minimum system requirements for Outlook for iOS app from iOS 14 to iOS 15.

Microsoft will retire support for watchOS 7. watchOS 8 and 9 will be the only supported versions for Apple Watch.

How does this affect me?

After iOS 16 is released, Outlook devices running iOS 14, or lower will no longer receive Office app updates.

At that time, customers will be able to continue to use the older version of Outlook for iOS. Once they update their device to iOS 15 or above, they will receive the newest version of Outlook.

Over time, Outlook for iOS on iOS 14 devices will eventually stop synchronizing email and calendar data, unless they have a supported version of iOS.

This change does not affect anyone using Outlook for iOS apps on iOS 15 or above.

What do I need to do to prepare for this change?

Microsoft recommends that you communicate this change to your users to ensure they update their device operating system.

Please click Additional Information to refer to the current minimum system requirements for Office 365.

Additional information

Article saved!

Access saved content from your profile page. View Saved