Windows Vista Restoration Error

Home Forums Client Operating Systems Windows 2000 Pro, XP Pro Windows Vista Windows Vista Restoration Error

Viewing 1 post (of 1 total)
  • Author
  • Avatar

    Good Afternoon,

    I am working on a friends Sony VAIO laptop with Vista Home Premium on it. I removed 1200 malicious files and the OS was so damaged by spyware that I had to restore the C: drive to factory defaults. The restoration went fine until the last reboot during the install process.

    After the reboot, I get a black screen and error window that says “Windows could not complete the installation. To install Windows on this computer restart the installation” and when you click OK or close the box it reboots the computer and displays the same error after.

    Once I see the “Windows could not complete…” error I hit CTRL – ALT – DEL, and kill “audit.exe”. Win Vista desktop appears with full control over the system (So there is nothing wrong with the installation). However, as soon as I reboot I get the “Windows could not complete…” error again.

    All I need to do is find the process that runs audit.exe and stop it from booting. Using regedit, I removed all boot processes that I could see save core hardware devices like sound and video. There are no runonce entries and using Sysinternals autoruns I turned off as many booting processes / services as possible.

    I am convinced one of the remaining Windows services controls this process as I have turned off everything else and am still encountering the error. If I change the password on the administrator account (default is blank) or create a new admin account the laptop crashes on boot with “security audit” errors and I get a black screen forcing me to restore again. Leaving a laptop with blank admin password is simply not acceptable to me so this has to be solved before I return it.

    I applied 94 Windows patches through Windows Update yesterday and applied SP1 + 2 today. Same error.

    The only thing left to do is convince Windows that the install is done successfully. At this point it is probably a registry entry that needs to be changed.

    I have done copious web searches to no effect. So how do I force the audit.exe program to accept the install is done?

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.