Win7 network access VERY slow.

Home Forums Client Operating Systems Windows 7 Win7 network access VERY slow.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • Avatar
    shadragon
    Member
    #156497

    Brand new Dell Optiplex 790 running Win7 Pro-32 bit and 4GB RAM is using only 2.5% of the available bandwidth according to the taskmgr.exe network page. It is an Intel 10/100/1000 NIC with latest drivers. The switch it is on is only 100 MB/s.

    On the 100 MB/s connection I started with 36K/s throughput out of the box. By doing the below I have brought it up to 136K/s but it is still VERY slow. Takes 60 seconds to copy a 10MB file from a network share to the desktop. 1-2 secs for the same file transfer on a XP box.

    Windows firewall is turned off and after reading a bunch of articles on the subject, I have done the following:

    – In ncpa.cpl
    Right clicked on adapter (select properties)
    Click on “configure”
    Click on “advanced”
    Selected property “Flow Control” and change it to “Disabled”

    – In the network adapter I changed it from “AUTO” to “100 MB – FULL”

    – Turned off “QoS Packet Scheduler” and “IPv6” protocols (We use IPv4 exclusively in-house) in the network properties window.

    – Ran the following commands in administrator DOS window:

    netsh int tcp set heuristics disabled
    netsh int tcp set global autotuninglevel=disabled

    I plugged the neighboring WinXP workstation into the jack used by the Win 7 machine and got 94-97% bandwidth throughput so it is the Win7 box that has the issue.

    Out of ideas at this point. Found an article saying that the power saver controls might cause this, but there are very limited options under the NIC power saving and none of the options listed in the article are on the NIC properties.

    Boss has already to me to sort it out or we will be putting the user back on XP. Not necessarily a bad thing, but dumb that Win7 only connects at 2.5% network speed out of the box.
    :rolleyes:

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.