USB Mouse and Keyboard freezes

Home Forums Client Operating Systems Windows 7 USB Mouse and Keyboard freezes

Viewing 1 post (of 1 total)
  • Author
    Posts

  • shadragon
    Member
    #163391

    Good day,

    A problem on my PC which was started out as annoying is now getting worse and directly linked to my mouse and keyboard. Here is my hardware setup.

    ASUS Crosshair Formula-Z Mobo
    AMD FX-8350 Eight core processor (No overclock)
    RevoDrive 3 X2 240 GB PCIe SSD
    MSI 7980 TwinFrozr PCIe Video Card
    32GB RAM
    Logitech Keyboard K120
    Logitech Optical Mouse MX 518
    Logitech wireless headset G920

    Running Windows 7, 64-bit, fully patched
    Mouse and KB have Logitech drivers (Latest) and are plugged directly into back of Mobo on USB 3.0 compliant ports.
    I have a USB Aquagate 7 port powered USB Hub also plugged into the back of the PC. That powers my phone recharger, external speakers, and G920 headset.

    The issue: When I move my mouse across the screen it moves 3″-4″, it freezes and I hear a ding-dung sound indicating a USB device has been disconnected. Then a second later another dung-ding sound and I can move my mouse again. Sometimes, (one in ten) when this happens the mouse goes completely dead (No light under mouse) and I have to physically unplug it and put it back in to get it active again. This also happens to my keyboard at times. Rather annoying when playing Dishonored or another PC action game. My wireless USB headset plays music or sound continually during these episodes. It is not interrupted at all.

    After reading other articles I have done the following:

    – Changed USB ports. Even ran them off the ports in the front of the PC.

    – Uninstalled all USB devices and rebooted. They reinstalled, no issues, and no yellow warning icons in Device Manager. No events in Event Manager.

    – Went into Power section of control panel and disabled all power saving modes on all devices including USB.

    – Gone into each USB device through Device Manager and turned off “Allow the computer to turn this device off to save power” on all USB hub Power Management entries.

    – Updated all Mobo drivers to latest BIOS and USB 3.0 driver versions.

    None of these made any difference. In fact, the situation is probably worse now than before. I’m getting the ding-dung every 2-3 minutes, sometimes as often as three in 30 secs at times.

    I am convinced this is an MS issue as I have zero problem when running Ubuntu Linux 12.10 on the same physical hardware. Mouse and KB work fine on my older XP box.

    Any assistance would be appreciated.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.

External Sharing and Guest User Access in Microsoft 365 and Teams

This eBook will dive into policy considerations you need to make when creating and managing guest user access to your Teams network, as well as the different layers of guest access and the common challenges that accompany a more complicated Microsoft 365 infrastructure.

You will learn:

  • Who should be allowed to be invited as a guest?
  • What type of guests should be able to access files in SharePoint and OneDrive?
  • How should guests be offboarded?
  • How should you determine who has access to sensitive information in your environment?

Sponsored by: