GET-IT: TEAMS DAY | 1-Day Free Virtual Conference all about Teams. Here on Petri.com - 8/12/20 GET-IT: TEAMS DAY - 8/12/20

the same command on same machine not run

Home Forums Scripting PowerShell the same command on same machine not run

Viewing 1 post (of 1 total)
  • Author
    Posts
  • Avatar
    mla
    Member
    #165709

    I successfully run PS yesterday. Took a copy.
    Today when run the same command on the same machine getting trouble. Tried different combinations. No luck…
    Why it is not consistent? And plz suggestion…

    Yesterday:

    PS C:nano-new> New-NanoServerImage -MediaPath C:NANO-NewISOsource -BasePath .Base -TargetPath .Nano1 -ComputerName Nano1 –GuestDrivers

    cmdlet New-NanoServerImage at command pipeline position 1
    Supply values for the following parameters:

    Windows(R) Image to Virtual Hard Disk Converter for Windows(R) 10
    Copyright (C) Microsoft Corporation. All rights reserved.
    Version 10.0.9000.0.amd64fre.fbl_core1_hyp_dev(mikekol).141224-3000 Beta

    Today:

    PS C:NANO-New> New-NanoServerImage -MediaPath C:NANO-NewISOsource -BasePath .Base -TargetPath .Nano1 -ComputerName
    Nano1 –GuestDrivers
    New-NanoServerImage : The term ‘New-NanoServerImage’ is not recognized as the name of a cmdlet, function, script file,
    or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and
    try again.
    At line:1 char:1
    + New-NanoServerImage -MediaPath C:NANO-NewISOsource -BasePath .Base -TargetPat …
    + ~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : ObjectNotFound: (New-NanoServerImage:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

    Suggestion [3,General]: The command New-NanoServerImage was not found, but does exist in the current location. Windows P
    owerShell does not load commands from the current location by default. If you trust this command, instead type “.New-Na
    noServerImage”. See “get-help about_Command_Precedence” for more details.
    PS C:NANO-New>
    PS C:NANO-New>

    Tried Suggestion:

    PS C:NANO-New> “.New-NanoServerImage” -MediaPath C:NANO-NewISOsource -BasePath .Base -TargetPath .Nano1 -ComputerN
    ame Nano1 –GuestDrivers
    At line:1 char:25
    + “.New-NanoServerImage” -MediaPath C:NANO-NewISOsource -BasePath .Base -Targe …
    + ~~~~~~~~~~
    Unexpected token ‘-MediaPath’ in expression or statement.
    At line:1 char:36
    + “.New-NanoServerImage” -MediaPath C:NANO-NewISOsource -BasePath .Base -Targe …
    + ~~~~~~~~~~~~~~~~~~~~~
    Unexpected token ‘C:NANO-NewISOsource’ in expression or statement.
    + CategoryInfo : ParserError: (:) [], ParentContainsErrorRecordException
    + FullyQualifiedErrorId : UnexpectedToken

    PS C:NANO-New>
    PS C:NANO-New>

    Folder structure:

    in attached file

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.