SQL Nightmare – cannot uninstall

Viewing 1 post (of 1 total)
  • Author
    Posts
  • Avatar
    Blood
    Member
    #161176

    Hi, folks

    I have a serious problem with a SQL installation which is part of an application installation. The installation is on a Windows 2008 server which is a member server on a domain.

    I am unable to use the application because it has been unable to update an existing installation of SQL Server Express 2005 with SQL Server Express 2008 SP1.

    I am unable to uninstall SQL Exp 2008 SP1 and need to do so in order to re-install the application and get it working. I am not concerned about keeping the existing instance.

    Note that I know very little about SQL.

    History:
    We use CA Arcserve V12 and Arcserve V12 used SQL 2005 Express to manage its database.

    Just under two weeks ago I upgraded Arcserve to r16. During the installation it tried to upgrade SQL 2005 Exp to SQL 2008 Exp SP1. During the upgrade it reported an upgrade failure with the message that the path could not be found.

    Setup continued, but because the SQL upgrade had failed, Arcserve reported encryption errors and, as expected, the database engine could not be started.

    I have spent over a week with Arcserve’s technical support with this and they just keep taking me round in circles – run the SQL Express 2008 uninstaller from Control Panel, if it fails reboot the machine, run the uninstaller, if it fails reboot the machine and on and on.

    I posted on CA’s forums and the guys there recommended a complete uninstall and reinstall. I have uninstalled Arcserve which was successful but when I tried to uninstall SQL I got the same path not found error.

    I posted in Microsoft’s SQL forums and received some help there from a guy who referred me to a thread recommending that certain registry keys be deleted and SQL folders on the computer be renamed. I did this, rebooted the server and tried to install SQL Server 2008 Express SP1 on its own. This failed with the same error message but this time a comprehensive report had been generated that detailed the installation steps and problems. I have uploaded the report and am hoping the guy on the MS forums who has been helping me will be able to determine the problem so it can be fixed.

    This was two days ago.

    What I’d like to know is, is there anyone who has run into this problem before. Were you able to solve it?

    I am not worried about keeping the existing instance as all the info can be retrieved from the backup tapes once Arcserve has successfully installed.

    I have contacted a local IT consultancy but they don’t have anyone who will be able to take it any further than I have done thus far. They said that the best option may be to open a support ticket with Microsoft.

    This is obviously an option but if it can be resolved with a little help from the forums that would be great.

    Any suggestions, please?

    Thanks!

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.