Server unable to "net send" any machine

Home Forums Server Operating Systems Windows Server 2000 / 2003 / 2003 R2 Server unable to "net send" any machine

Viewing 1 post (of 1 total)
  • Author
    Posts

  • humbletech99
    Member
    #129189

    I have a server that is not able to “net send” any machine. It is running Windows 2003 server and has the messenger service disabled so that it does not receive any incoming “net send” messages. However there is another server that also has the messenger service disabled and can net send out.

    Reason I need this: Users run processes on the servers and have these commands at the end of their batch files to let them know when their process has finished.

    I have checked all the services manually and the working server does not have any service the broken one does not have. There were a couple of things in netdiag however that I do not quite understand

    Code:
    NetBT name test. . . . . . : Passed
    [WARNING] At least one of the <00> ‘WorkStation Service’, <03> ‘Messenger Service’, <20> ‘WINS’ names is missing.

    NetBT transports test. . . . . . . : Passed
    List of NetBt transports currently configured:
    NetBT_Tcpip_{3CACDC42-9112-412B-A05D-C647833F7952}
    1 NetBt transport currently configured.

    NetBT name test. . . . . . . . . . : Passed
    [WARNING] You don’t have a single interface with the <00> ‘WorkStation Service’, <03> ‘Messenger Service’, <20> ‘WINS’ names defined.

    DNS test . . . . . . . . . . . . . : Passed
    [WARNING] Cannot find a primary authoritative DNS server for the name
    ‘servername.domain.com.’. [RCODE_SERVER_FAILURE]
    The name ‘servername.domain.com.’ may not be registered in DNS.

    I suspect I have these NBT warning because the messenger service is disabled, they were not on the working server when I ran netdiag on it but it also has the service disabled. Both servers rebooted on Wednesday at the same time.

    I have run nbtstat against both servers and can see the missing name is the 03 messenger service name on the non-working server.

    The dns error is a bit perplexing too since I have manually queried every dns server in the list that the non-working server uses. Queries for the servername.domain.com as well as just servername, both forward and reverse, came back successful every single time I queried any of the dns servers, so I don’t know what this is really complaining about.

    The working server has not had any of these messages in it’s netdiag which passed everything.
    I have even gone through the network settings, making sure netbios over tcp is enabled and that the dns and wins server settings are identical.

    I’ve done ipconfig/flushdns and nbtstat -RR and nbtstat -R but still no joy.

    Can anyone please give me some ideas on things to do here, I’m running out…?

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.

13 Email Threat Types to Know About Right Now

As email threats evolve and multiply, keeping track of them all—and staying protected against the many different types—becomes a complex challenge. Today, that requires more than just the traditional email gateway solution that used to be good enough.

In this eBook you will learn:

  • What are the most common and challenging email attacks for organizations?
  • How to defend against sophisticated email threats, such as spoofing, social engineering, and fraud
  • How to protect employees at the inbox level with the right technologies and security-awareness training
  • How to use a multilayered protection strategy to reduce susceptibility to email attacks and better defend your business and employees

Sponsored by: