Running an MSI remotely

Home Forums Scripting PowerShell Running an MSI remotely

Viewing 1 post (of 1 total)
  • Author
    Posts
  • Avatar
    RicklesP
    Member
    #164256

    I’ve been chasing this for a week now, and I’m stumped. I have a need to install an MSI, but it can’t be pushed thru Group Policy because the prior version was installed during OS deploy, must be manually removed first, and the machine restarted before new install. I’ve got a script assembled which:
    *-Reads all PCs from AD
    *-Checks each to verify on-line status
    *-Checks the version of install for this app
    *-Removes it and restarts if old version
    *-Installs new if no version installed
    *-Records complete if new version installed

    The plan is to WOL all domain client PCs, then run the script to force the removal. Then run the script again to force the install, both during the night hours when users aren’t in. Anything that misses out can be done manually, once the log files are examined.

    Tried using a per-machine script as a Scheduled (startup) Task, failed. Task was denied access every time GP refreshed (haven’t begun to research that!) All the scripts options work except the install itself. The script copies a network share to the local PC, then issues ‘Invoke-Command {cmd /c ‘msiexec /i C:.msi /qn /log ‘}. Running it that way executes MSIEXEC enough to open the msi file, then start recording events. The log file has a collection of ‘action start’ and ‘action ended’ statements at the beginning of the file. They end with 3 lines that I think highlight the problem, that either MSIEXEC or the msi itself thinks “…the profile for the user is a temporary profile.” Since this is running remotely from a management server under a domain admin account, with the ISE running under elevated privs, authority shouldn’t be an issue. I’ve tried running under the domain ‘god’ account with the same results. I’ve also tried calling a PSSession under the same creds and running the install inside that session, same failure.

    I can call just the network shared MSI file from a Run box when logged in as an interactive admin user to any destination PC, and the install works flawlessly. The msi itself forces a restart when complete.

    Anyone got any ideas? The vendor of the MSI say it’s not their software mandating an interactive login, and I’m out of answers.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.