RPC over http doesn’t work even with a GoDaddy Certificate

Home Forums Messaging Software Exchange 2000 / 2003 RPC over http doesn’t work even with a GoDaddy Certificate

Viewing 1 post (of 1 total)
  • Author
    Posts
  • Avatar
    AndrewR
    Member
    #127658

    I’m having a similar problem.

    Some information:

    two servers:

    1 – Exchange 2003 server, all SPs installed, updated. (W2k3 R2, enterprise, 32 bit edition)
    2 – W2k3 r2 DC, (Enterprise, x64 bit edition)

    I went through the setup instructions on Petri, and initially had forgotten to do the GC entry on the DC. Fixed that, and I have followed the instructions. Yet, I cannot connect via RPC over HTTPS using it.

    Some info:

    1) We’re using a certified certificate, from one of Go Daddy’s subsidiaries. It’s installed, and working correctly. Up until yesterday, we were using a self-created SSL cert.. but now, we have a 10 year certificate. Much better, and externally verified. DC was running as a CA, but now uninstalling CA on the DC, and using external SSL only.

    2) The firewall is a Watchguard X5000 appliance. OWA works fine, so ports 80 and 443 are working through the Firewall, and forwarded to the appropriate server. Yet I can’t seem to get RPC over HTTPS to work. Do I need to have RPC installed on my DC as well? And do I need to configure RPC similarly to what I did on my exchange server?

    3) I have configured my client on the LAN to use RPC over HTTPS proxy, and when I run outlook.exe /rpcdiag, it’s showing me it’s using TCP/IP traffic. When I try an external client.. no luck at all. I’ve tried using the TCP packet filtering.. but to no avail. Doesn’t appear that the traffic is working. I have rebooted my DC since the change, as well as the Exchange server.. but still it does not work. Help?

    Any help would be appreciated. thanks.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.