GET-IT: TEAMS DAY | 1-Day Free Virtual Conference all about Teams. Here on Petri.com - 8/12/20 GET-IT: TEAMS DAY - 8/12/20

Reporting not working in SCE 2007 after SQL 2005 Express upgraded to SQL 2005 Standar

Home Forums Microsoft Networking and Management Services System Management Reporting not working in SCE 2007 after SQL 2005 Express upgraded to SQL 2005 Standar

Viewing 1 post (of 1 total)
  • Author
    Posts
  • Avatar
    Taw_Jackson
    Member
    #140001

    Hi there

    Due to reporting requirements, I performed an in-place upgrade on a SCE 2007 server of SQL Server 2005 Express Edition to SQL Server 2005 Standard Edition.

    Only upgrading Reporting Services caused any challenge, and in the end we had backup the databases, uninstall Reporting Services completely, install Reporting Services and restore databases.

    Seemed to go ok, until I tried to access a report (any default report).

    Instead of the report loading I get this error message:

    • Failed to load expression host assembly. Details: Could not load file or assembly ‘Microsoft.EnterpriseManagement.Reporting.Code, Version=6.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35’ or one of its dependencies. Failed to grant minimum permission requests. (Exception from HRESULT: 0x80131417) (rsErrorLoadingExprHostAssembly)

    I get this same emssage whether I try to access a report from within SCE reporting or from SQL Report Manager.

    I’ve got to be honest and say I have no idea what that error message is telling me.

    I’m not a SQL admin to begin with, and am at a loss.

    Has anyone encountered this issue before?

    has anyone resolved it without rebuilding the entire server (sadly not an option)?

    If so, would very much like to hear from you.

    Best regards

    Taw

    Report post as abusive

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.