RemoteApp only runs as Administrator

Home Forums Server Operating Systems Windows Server 2008 / 2008 R2 RemoteApp only runs as Administrator

Viewing 1 post (of 1 total)
  • Author
    Posts
  • Avatar
    cestor
    Member
    #156146

    I have the following problem which if anyone can help me with it would be appreciated!

    I have a Windows 7 client, a 2008 R2 Hyper-v Server, with a Windows 7 VM running. I want to run an app (just notepad to start with on the VM)

    I have the modified RDP file with the following lines added to the end

    remoteapplicationmode:i:1
    Alternate shell:s:rdpinit.exe
    RemoteApplicationName:s:remote notepad
    RemoteApplicationProgram:s:notepad
    DisableRemoteAppCapsCheck:i:1
    Prompt for Credentials on Client:i:1

    and added the necessary name and path registry keys on the VM

    Everything works fine when I run the RDP client as Administrator and a remote notepad window comes up. When I run as a normal domain user though, nothing happens. The normal domain user can establish a normal RDP session to the VM, and has access to notepad in that session.

    Any ideas?

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.