Problem running some (not all) shortcuts in Windows 7 path

Home Forums Client Operating Systems Windows 7 Problem running some (not all) shortcuts in Windows 7 path

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #154119

    Evening all,

    I’m having an issue running some applications on a Windows 7 machine.

    Background – on my computers, I usually create a folder in the root of the C drive called pathapps which I add to my system path variable. I also add the extensions .LNK and .JAR to my pathext variable, to allow the execution of shortcuts and Jars.

    Within pathapps, some executables are stored in the root folder and I can launch those fine from a Run box or the ‘Search’ box at the bottom of the Start menu. Others are stored in subfolders (rarely more than one level down though). For these apps, I create a shortcut to them in the root folder, to allow running them from a Run box – on XP at least, adding a folder to the path doesn’t include its subfolders.

    On this machine, under pathapps, there are two folders called KeePass-2.14 and PuTTY-x86. I’m sure I don’t need to describe what’s contained in those folders :)

    In pathapps, there are the following shortcuts:

    • pageant to pageant.exe in PuTTY-x86
    • plink to plink.exe in PuTTY-x86
    • pscp to pscp.exe in PuTTY-x86
    • psftp to psftp.exe in PuTTY-x86
    • putty to putty.exe in PuTTY-x86
    • puttygen to puttygen.exe in PuTTY-x86
    • puttytel to puttytel.exe in PuTTY-x86
    • keepass to KeePass.exe in KeePass-2.14
    • pathapps to the folder C:pathapps

    The keepass and pathapps shortcuts work fine. Trying to launch any of the others from Run results in the error dialog “Windows cannot find ‘‘. Make sure you typed the name correctly, and then try again.”

    All of the shortcuts were created by copying the executables and pasting shortcuts. All of the shortcut icons are correct (suggesting that Windows is able to determine where they’re pointing) and the Target and Start in attributes of each shortcut are correct.

    I’m able to double click on the shortcuts in pathapps and the executable runs and I can start the app by entering the full path to the exe in the Run box. Entering the path to the shortcut file (for instance C:pathappsputty.lnk) at the Run box results in the same error though.

    I’m not currently able to try this on any other Windows 7 machines. The executables were all downloaded from the relevant websites and I’ve unblocked them since downloading (in the exe file properties).

    System is running OEM Windows 7, was Home Premium but I entered my Ultimate key before activating, so I’m running Win 7 Ultimate. Arch is x64. Fully up to date, except for SP1 – waiting until I get time to image the hard drive before I install that. Nothing of note in the event logs and no other issues with the machine.

    I skipped the Windows 7 Beta, but installed the RC and didn’t experience this problem. I also didn’t have the problem on either XP or Vista.

    Windows Defender is enabled, but disabling it makes no difference. Antivirus is NOD32 4 (AV, not Smart Security) – disabling that also makes no difference. I have Directory Opus installed as my Explorer substitute, but again, removing that makes no difference.

    My user account owns the folder tree and all files within it and I have Full Control over them. I’m a local administrator and have the same problem regardless of whether UAC is enabled or disabled. Machine isn’t on a domain. System volume is the only HDD partition, there are no NTFS volumes mounted as folders.

    This is a relatively new machine – only a few months old. The shortcuts causing a problem have never worked on this machine. I’ve tried re-downloading the exes and recreating the shortcuts, without success.

    I can move the executable to the root pathapps folder and then it works fine. The problem with doing this is that I will want to add various other executables in the future, some of which create config files and other detritus in the directory they’re located in. For tidiness I would therefore want these ones to be in their own subfolder.

    Don’t really know what to try next. Researching the problem on Google hasn’t revealed anyone else having this problem. If anyone has any suggestions it’d be greatly appreciated :)

    Let me know if any more info required.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.