OOF Auto Reply "Loops" when addressed to internal invalid recipients

Home Forums Messaging Software Exchange 2000 / 2003 OOF Auto Reply "Loops" when addressed to internal invalid recipients

Viewing 1 post (of 1 total)
  • Author
    Posts
  • Avatar
    mb17
    Member
    #162768

    Has anyone had this problem in the past and resolved?

    Steps to reproduce:

    I added an SMTP Connector to route mail through a designated smart host. Previously I had no SMTP connectors configured.

    The following scenario happens:

    1- A NULL (Fake/Invalid) internal sender sends an email to an internal recipient (we have many of these in our organization that send mail, generally from a service or application, however, it’s also a concern for spoofing sender addresses)

    2- If the internal recipient has their out of office enabled, it responds to the null sender

    The auto response addressed to the null sender causes a continuous loop (verified through message tracker).

    Message Tracker Shows:

    SMTP: Store Driver: Message Submitted from Store
    SMTP: Message Submitted to Advanced Queuing
    SMTP: Started Message Submission to Advanced Queue
    SMTP: Message Submitted to Categorizer
    SMTP: Message Categorized and Queued for Routing
    SMTP: Message Queued for Local Delivery
    SMTP: Message Delivered Locally to invalid address @ internal domain .com
    SMTP: Store Driver Submitted Message to MTA
    SMTP: Store Driver: Message sumitted from Store
    SMTP: Message Submitted to Advanced Queuing
    SMTP: Started Message Submission to Advanced Queue
    SMTP: Message Submitted to Categorizer
    SMTP: Message Categorized and Queued for Routing
    SMTP: Message Queued for Local Delivery
    SMTP: Message Delivered Locally to invalid address @ internaldomain .com
    ** The above “loop” repeats approximately 6 times per minute.

    Problems:

    -There is no NDR generated

    – The transaction log grows at an exponential rate as more and more “loops are created by users who have their out of office enabled and begin auto replying to the null senders.

    – Additional CPU, memory and swap space is consumed.

    – After a period of time, the mailstore dismounts for unknown cause – possibly due to file space, memory resources unavailable, cpu unavailable…

    Temporary Resolution:

    When the connector is deleted, the message sender immediately receives an NDR that the message was unable to be delivered and the “loop” stops.

    Environment:

    Server 2003 R2 Standard SP2

    Exchange 2003 Enterprise

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.