MIIS hotfix installation error

Home Forums Server Operating Systems Windows Server 2000 / 2003 / 2003 R2 MIIS hotfix installation error

Viewing 1 post (of 1 total)
  • Author
  • Avatar


    I have a problem installing a hotfix for MIIS. I am already thinking the installation package is messed up.

    Here’s the link to the hotfix:
    Update for Microsoft Identity Integration Server 2003 SP1 (KB842531)

    When I start the installer, it goes ok validating the package. After that, I get few errors about xxxx.TMP files.

    Errors are of this form:

    Error 1328.Error applying patch to file C:Config.Msi[xxxx].tmp. It has probably been updated by other means, and can no longer be modified by this patch. For more information contact your patch vendor. System Error: -1072807676

    There are options abort, retry and ignore in these error messages.

    I have tried these things:

    • Press ignore in all error messages
    • Delete the xxxx.tmp files before trying to press retry or ignore
    • shutdown SQL before applying the patch

    None of the things above have helped.

    If trying to ignore all the error messages, installation goes through. You can check from MIIS about-screen that the version is correct (3.1.1042). But when I go to check miiserver.exe properties-> version -> file version says 3.1.1026.0 which is the previous version.

    If SQL is shutdown before starting the installer, the installer won’t start the validating the package.

    Here’s a similar problem as mine:
    Thread in microsoft.public.metadirectory

    Q1: Could it be solved by extracting the MSI package and then trying to install?
    Q2: If extracting the package would help, with what tool can you do it (for free)? With Flexnet SMS edition you can’t do the extracting atleast.
    Q3: Any other suggestions?
    Q4: Anyone else had similar problems?

    Thanks for help in advance,



    System Specs:
    -Win 2003 Enterprise
    -SQL2000 with SP4 installed
    -MIIS with SP1 installed

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.