GET-IT: TEAMS DAY | 1-Day Free Virtual Conference all about Teams. Here on Petri.com - 8/12/20 GET-IT: TEAMS DAY - 8/12/20

Lost Connectivity and Active Directory after installing/uninstalling NPS

Home Forums Server Operating Systems Windows Server 2008 / 2008 R2 Lost Connectivity and Active Directory after installing/uninstalling NPS

Viewing 1 post (of 1 total)
  • Author
    Posts
  • Avatar
    Blood
    Member
    #155212

    Hi, Folks

    I have a serious problem with a Windows 2008 Standard domain controller.

    There are two DC’s, the affected one and a W2k3 DC.

    What happened:

    I have been looking into Network Policy Server and decided to install the RRAS role as a start to see how it looked and to test it out. I did this via Remote Desktop while logged on as the domain administrator.

    I installed the role via Server Manager, choosing Routing and Remote Access and nothing else. I chose the first option to handle VPN connections. (I did not write this down so my terminology will be off). I told it to get DHCP addresses from the domain and not to assign them itself.

    After the installation finished, which was successful, a message appeared about a configuration option with a link to a help topic. I clicked the link and it displayed information about setting the DHCP relay server. When I closed the help file, NPS was shown in the list of roles in Server Manager, and Routing and Remote Access was visible off that. When I clicked it, there was a message to configure it and it asked for the DHCP information so I entered the IP address of our DHCP server which is the W2k3 domain controller.

    When I clicked OK there was a pause and then the Remote Desktop connection died.

    No problem, I thought, so I went to the server and logged on. The network icon showed local access only, although the network could not be reached. Mapped drives on the 2008 machine could not be accessed, and trying to connect to a machine using a UNC path failed. Pinging the 2008 server from another machine failed.

    So, I thought, right let’s try and reverse this. I used the Server Manager to uninstall NPS. This went fine and it requested a restart. After restarting and logging back in the uninstall completed successfully. Unfortunately, the machine was still unable to connect to the network.

    The problem is that Active Directory cannot be accessed either. When I try to open ADUC a message appears:

    Code:
    Naming information cannot be located for the following reason:
    The server is not operational.

    When I use the network diagnostic to check the connection the following is shown:

    Code:
    The following policy might need to be adjusted to allow Windows to connect:
    Policy provider: Filter Name:local send filter driver filter

    The network is shown as a Private network. A red cross exists between the network and the Internet on the diagram in the Network and Sharing Center.

    I tried running DCDiag but it failed with an LDAP error.

    Another check I ran (I can’t remember which – sorry) said that the Primary DNS was OK.

    I have also tried disabling the firewall via services.msc

    I can view active directory on the 2003 domain controller without any problems.

    Unfortunately, I had to leave the office and will not be able to get back to the server until Sunday.

    I have system state backups from Thursday.

    I am quite busy this weekend, but will be scouring the net for any information when I can.

    Does anyone know how I may remedy this? If anyone has any suggestions about how I might recover active directory and connectivity on this server between now and Sunday I will be truly grateful.

    Thanks.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.