Losing Display after Putting quad card

Home Forums Other General Hardware Losing Display after Putting quad card

Viewing 1 post (of 1 total)
  • Author
    Posts
  • Avatar
    IceNine
    Member
    #142900

    Ok here’s a weird problem.

    We’ve received a new batch of small form factors from HP. the new DC7900 SFF to be exact with the the Core 2 Quad. The quad card in question is the ATI FIREPRO 2450 PCI-E. I will get more HW info from the desktop and list it here in a bit. Installed WinXp Pro SP3 VLA. Setup would give me a BSOD after copying the files and after a bit of tweaking i had to switch the SATA Emulation from AHCI to IDE. Once i did this windows setup was able to continue. I have NO idea why this needed to be done when the pre-loaded OS was working with emulation in AHCI, but alas, i don’t think that’s the problem. Installed windows, applied all necessary updates installed our base software and took an image of the desktop. Dropped the image on a new PC, again having to change the SATA emulation to IDE but everything seemed to be working fine. Re-SIDed the second PC, joined to the domain and continued installing the rest of the software for the particular user. Finally dropped the ATI FirePro 2450 in it and rebooted. Here’s the problem now. The card goes into a full PCIE slot. When rebooting, i get the POST screen fine and it starts loading windows. At the windows screen the blue bars go across 4-5 times and then the screen goes blank. have waited upwards of 15 minutes and the screen never returns. The pc continues to boot up and actually i am able to log in. (fumbled my way through the log in process but once i got it right i can hear the windows logon sound.) I am at a loss. If i put the card in an OTB dc7900 with the pre-loaded OS it seems to work fine. chipset/bios drivers are the same on both PC’s. I tried one of our full PCIE Nvidia Quadro NVS 290 dual cards and that worked like a charm. I was able to get the PC in question as a quad setup with 2 dual cards, one full PCIE and one Express. But this is not a viable solution. Also i was able to boot into safe mode but unable to install the ATI Drivers. Anyone have any insight on this? Maybe come across a similar problem?

    Any help is appreciated.

    Thanks

    Ice
    ***Update***
    Found the issue and resolved it. Well it looks like the ATI card does not disable the Intel Embedded Video Controller on the new DC7900’s. Just for kicks i plugged in a cable to the on board VGA and lo and behold there i was greeted with the Windows log on screen. Logged in installed the ATI drivers, rebooted, same issue. Plugged vga cable again, logged in, checked device manager and saw that the embedded intel controller was still showing in the Display Adapters list. Disabled that and rebooted. PC works like it should. I”m guessing this is probably something to do with the new chipset drivers for the new PC’s. Every other DC model we’ve had automatically disables the embedded controller but i’m not 100% convinced of that. I did not have to disable the controller in the DC7900 when i put in the 2 dual cards from Nvidia. It automatically did it. Is it the card then? I don’t know. I’m glad that i was able to work it out though. Hopefully this helps someone with similar issues.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.