How to get ADSL dsl thru Cisco 2501 serial ports.

Home Forums Networking Cisco Routers & Switches How-to How to get ADSL dsl thru Cisco 2501 serial ports.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • Avatar
    cvgccjax
    Member
    #118674

    Hi

    I have (2) Cisco 2501’s and I need some help routing my ADSL dsl connection thru Router-A to Router-B. I have a 1900 switch too. My dsl router connects to Ethernet0 on the 2501-A and I am able to receive an internal ip address. I was able to find the configuration to make this happen.

    Ethernet0 172.16.1.10 YES DHCP up up

    Serial0 unassigned YES manual down down

    Serial1 unassigned YES NVRAM administratively down dow

    Here is the configuration I found, however it was for a 2514 instead.

    Current configuration : 1074 bytes
    !
    version 12.3
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    service udp-small-servers
    service tcp-small-servers
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    ip subnet-zero
    ip dhcp excluded-address 192.168.1.1
    !
    ip dhcp pool insideDHCP
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.1
    dns-server 207.69.188.186 207.69.188.185
    !
    !
    !
    !
    interface Null0
    no ip unreachables
    !
    interface Ethernet0
    description Facing the ISP
    ip address dhcp
    ip nat outside
    no ip route-cache
    no ip mroute-cache

    interface Ethernet1
    description Facing my LAN
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    no ip route-cache
    no ip mroute-cache

    interface Serial0
    no ip address
    no ip route-cache
    no fair-queue
    !
    interface Serial1
    no ip address
    no ip route-cache
    shutdown
    !
    ip nat inside source list 1 interface Ethernet0 overload
    ip http server
    ip classless
    !
    !
    access-list 1 permit 192.168.1.0 0.0.0.255
    !
    !
    line con 0
    line aux 0
    transport input all
    line vty 0 4
    login
    !
    end

    I tried to jeryrig this config to where the configurations ethernet1 would be my serial0, but no luck there. Does anyone have a dummy configuration or some advice on how to router an internet connection through serially? Thanks

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.