GAL does not update for 3 days

Home Forums Server Operating Systems SBS 2000 / 2003 / 2008 / 2011 GAL does not update for 3 days

Viewing 1 post (of 1 total)
  • Author
    Posts
  • Avatar
    PaulH
    Member
    #126390

    I have a client with a single SBS2003 server and 13 XP pro workstations. When he adds a new distribution group or changes the name of an existing distribution group, he uses Outlook Web Access to send that group an email.

    However, the Global Address List does not show the changes that he just made in ADUC. He waited overnight, and even after 3 days the changes were not showing up in OWA’s GAL.

    I’ve read Daniel Petri’s GAL Problems article, which talks about the Outlook address book (offline and online etc.) but my problem is not using Outlook at all.

    I’ve had it happen before when the GAL does not reflect recent alterations – a newly added user can’t receive an email because users cannot find him in their Contacts list – that sort of thing. the steps I take when this happens are as follows:

    1. Wait overnight
    2. send the user (or distribution group) an email from outside the organisation
    3. stop and restart the Exchange services (which sometimes hang, permanently “stopping…” so I have to be prepared to do step 4.)
    4. restart the server (ouch!)

    Now, I am wholly uncomfortable with the last two options, but sometimes it’s the only thing that does the trick. After restarting, the newly created user (or dist group) is there in the GAL.

    How do I force the GAL to update itself faster? Or, is there a way to manually get the GAL to update “now” so to speak?

    I understand that an Exchange Server needs to be near the GC server but this scenario is for a single SBS box in a small environment, so I can’t find much on google about this particular problem.

    In my most recent example of this problem, nobody is using Outlook at all, they all use OWA from their workstations and from outside the building.

    Thank you.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.