Exchange online archiving not working

Home Forums Office Office 365 Exchange online archiving not working

Viewing 1 post (of 1 total)
  • Author
    Posts
  • Avatar
    curious_7
    Member
    #624790

    We have on-premises exchange 2016 servers and the exchange online archiving was setup by someone before me.
    But the automatic archiving is not working. User emails are not getting moved to the online archive automatically.

    The previous administrator had indicated to the business that this is due to OAuth not being setup and thus needs to be setup.

    It seems the issue started after the migration was done to Exchange 2016 from Exchange 2010. Archives used to work on exchange 2010.
    For one of the users having problem I noticed that the “msExchArchiveStatus” attribute was not set & in EAC the archive mailbox status was “Cloud based archive pending”. This user’s setup is different though because their primary mailbox is in Office 365 as well (whereas most our users have mailbox on-premises). This user can see the archive mailbox and can manually move emails to it. But auto-archive is not working. My guess for this user is that the MRM policies are not set in Office 365 and so the auto-movement of emails to archive is not working.
    For another user who has mailbox on-premises they could not even see the archive mailbox in outlook. IN EAC the archive mailbox status is “Cloud-based archive created”. “msExchArchiveStatus” attribute is set to “1”. But “msExchArchiveName” is set to “Personal Archive – UserName” instead of “In-Place Archive – Username”. Is that because she might have had the archive on a on-premises archive database? And the cloud based archive mailbox is not showing for her because this field was not cleared?
    As it was working with Exchange 2010 would OAuth be an issue? One more thing I noticed was that there is a send connector to Office365 but not from Office 365 in the EAC. Could this be because the Hybrid configuration wizard was not run properly when Exchange 2010 was there? And could this be causing issues as well?

    I went through the ELC logs using the article below:-

    https://blogs.technet.microsoft.com/vikass_blog/2017/05/12/why-is-mfa-not-moving-archiving-or-deleting-expired-contents-from-the-mailbox/

    And got the following error listed after using the command – “Export-MailboxdiagnosticLogs ” mailbox” -ComponentName MRM” :-

    MailboxLog : 5/11/2019 12:17:56 PM Exception: Microsoft.Exchange.MailboxAssistants.Assistants.ELC.ElcEwsException:
    ELC EWS failed with error type: ‘ArchiveExchangeWebServiceNotAvailable’. Message: Archive EWS url is
    unknown.
    at
    Microsoft.Exchange.MailboxAssistants.Assistants.ELC.RemoteArchiveProcessorBase..ctor(MailboxSession
    mailboxSession, ADUser user, StatisticsLogEntry statisticsLogEntry, Boolean isCrossPremise, Boolean
    isTestMode, MailboxesInformation archiveMailboxesInformation)
    at Microsoft.Exchange.MailboxAssistants.Assistants.ELC.ArchiveProcessorFactory.Create(ArchiveLocation
    archiveLocation, MailboxSession mailboxSession, ADUser adUser, StatisticsLogEntry statisticsLogEntry,
    Boolean isTestMode, MailboxesInformation archiveMailboxesInformation)
    at Microsoft.Exchange.MailboxAssistants.Assistants.ELC.MailboxData.get_ArchiveProcessor()
    at Microsoft.Exchange.MailboxAssistants.Assistants.ELC.ElcUserTagInformation.SaveConfigItem(MailboxDat
    aForTags mailboxDataForTags)
    at
    Microsoft.Exchange.MailboxAssistants.Assistants.ELC.TagProvisioner.InvokeInternal(MailboxDataForTags
    mailboxDataForTags)
    at Microsoft.Exchange.MailboxAssistants.Assistants.ELC.TagProvisioner.Invoke(MailboxDataForTags
    mailboxDataForTags)
    at
    Microsoft.Exchange.MailboxAssistants.Assistants.ELC.ElcTagSubAssistant.InvokeInternal(MailboxSession
    mailboxSession, MailboxDataForTags mailboxDataForTags)
    at Microsoft.Exchange.MailboxAssistants.Assistants.ELC.ElcTagSubAssistant.Invoke(MailboxSession
    mailboxSession, MailboxDataForTags mailboxDataForTags)
    at Microsoft.Exchange.MailboxAssistants.Assistants.ELC.ELCAssistant.InvokeCore(MailboxSession
    mailboxSession, List`1 customDataToLog, StatisticsLogEntry logEntry, ElcParameters parameters)
    at Microsoft.Exchange.MailboxAssistants.Assistants.ELC.ELCAssistant.<>c__DisplayClass30_0.<InvokeInter nalAssistant>b__1() ………………………………………………………………………..

    Following Microsoft support article seems to indicate that CU12 and later have fix for this:-
    https://support.microsoft.com/en-us/help/4468363/mrm-not-working-for-mailboxes-that-have-online-archive-mailbox

    I have already applied CU13.
    But I ran the MFA again manually for the mailbox I was testing with, but it still is generating the same error.

    Could it be the incorrect configuration of the URLs?
    I checked the EWS url and it points to mail.ourdomain.com. This is a alias to our load balancer A record. Load balancer then distributes this to our mail servers.

    How can I check the ArchiveExchangeWebService URL (if there is such a url defined)?

    Somewhere I read that exchange server needs to have direct connectivity to office365 so I removed the proxy from the IE settings and was still able to get to microsoft.com.

    What could be causing the ‘ArchiveExchangeWebServiceNotAvailable’ error?

    Also, as we are on CU13 now, we can use Modern Hybrid auth instead of OAuth. Is that correct?

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.