Domain Controller not updating from WSUS

Home Forums Server Operating Systems Windows Server 2008 / 2008 R2 Domain Controller not updating from WSUS

Viewing 1 post (of 1 total)
  • Author
  • Avatar
    Karl Bracken

    Hi All,

    I have just inherited some existing issues in my new Sys Admin position, as i have never used WSUS before i thought i would ask you fine people for some input!

    All servers are 2008R2, 2 physical servers running Hyper-V and these run 8 Virtual machines, each physical has one domain controller on it.

    One of the virtual domain controllers is not taking MS Updates, a few months ago it did then something happened and it changed, so WSUS is not updating it and when i try it manually i am getting Error code: 8000FFFF, the other DC is updating fine

    When i check C:Windows windowsupdate

    Setup Downloading setup package “WUClient-SelfUpdate-Core-TopLevel~31bf3856ad364e35~amd64~~7.6.7600.256”

    Setup Downloading setup package from [url]http:/local:/selfupdate/WSUS3/x64/Vista[/url]

    Misc Validating signature for

    Misc Microsoft signed: Yes


    WARNING: LoadLibrary failed for srclient.dll with hr:8007007E
    Setup Staging setup package “WUClient-SelfUpdate-ActiveX~31bf3856ad364e35~amd64~~7.6.7600.256”
    Setup WARNING: CBS staging operation failed, error = 0x8000FFFF
    Setup FATAL: Failed to stage setup package “WUClient-SelfUpdate-ActiveX~31bf3856ad364e35~amd64~~7.6.7600.256”, error = 0x8000FFFF
    Setup WARNING: Failed to stage applicable setup packages, error = 0x8000FFFF
    Setup FATAL: Downloading binaries for SelfUpdate failed, err = 0x8000FFFF
    Agent * WARNING: Skipping scan, self-update check returned 0x8000FFFF
    Agent * WARNING: Exit code = 0x8000FFFF

    I have checked the registry as suggested in KB946414 and the values were not in it on the server running WSUS and the values are not there.

    I tried installing the SURT but it just hangs about half way through, i have also just tried updating as normal and im getting event ids 1001 and 256, any thoughts on this?

    Could it be folder permissions?

    I have also looked at the group policy and when i check the settings, im getting An error has occured while collecting data for administrative templates

    namespace ‘Microsoft policies……..’ is already defined as the target namespace for another file in the store

    Any help would be greatly appreciated,


Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.