Can’t break mirror?

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • Avatar
    wkearney99
    Member
    #150255

    I’ve got a 2008R2 server running off a software mirror from two disks. There’s a parallel install (or was) install on the 1st partition, mounted as C:. The running OS is on the 2nd partition, mounted as D:. This was working fine. In the past with w2k and 2003 servers I could simply break the mirror and reboot. No so with 2008R2. When I try it complains about the plex being part of the boot or system. STFW brought up an MS note suggesting use of an elevated cmd prompt and the diskpart program. Tried that, same error! WTF?

    What I’m after here, is to move everything off these two software mirrored drives and onto a 4 drive hardware RAID5. The OS has the drivers loaded already (jmicron). I’ve tested it by creating a RAID5 and it comes up in the OS just fine. Anyway.

    But in order to get the machine state backed up properly (more importantly, restored) I’ve got to ditch the mirror. I can’t reload a bare metal or system state unless it sees two ‘drives’ on which to recreate the software mirror. Trust me, I’ve tried. A bare metal backup refused to use the single (and much larger than before) RAID5 volume. Same deal with one with the system state. I would’ve preferred to avoid going the whole reinstall the OS route.

    So what’s the deal? How do I get the mirror broken? Can I safely break it using just the setup DVD? Or via booting into a parallel OS?

    Help!

    Avatar
    strader
    Participant
    #651437

    Since i don`t see any replies here, would post what worked for me.

    In or situation clean installation was not an option due to multitude of custom configurations that would be practically impossible to recreate.

    Background:
    OS – Server 2008 R2
    2 hard drives, mirrored, 1x system reserved and 1x data partitions

    Data partition got corrupted on drive 1
    Only secondary plex was loading when both drives are on
    Disconnecting disk 1 and trying to boot from disk 2 did not work

    Removing mirror on data partition was not an issue,
    System Reserved partition did not work with same error as OP (part of the boot or system)

    We ended up connecting third drive and cloning system using AOMEI Backupper cloning functionality that took a working system reserved partition from drive 1 and data partition from drive 2
    I am sure there are other applications that can work just as good on that method

    After that i have connected only cloned drive and reformatted MBR.

    Worked, no mirror left to speak of, OS loading from single drive, all configurations and databases online

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.