adprep /rodcprep fails with ForestDnsZones

Home Forums Microsoft Networking and Management Services Active Directory adprep /rodcprep fails with ForestDnsZones

Viewing 1 post (of 1 total)
  • Author
    Posts
  • Avatar
    StixNZ
    Member
    #156524

    Hi

    I am trying to upgrade my domain controllers and I am having issues with the “adprep /rodcprep” command.
    The error I receive is:

    Adprep found partition DC=ForestDnsZones,DC=example,DC=local, and is about to update the permissions.
    Adprep could not contact a replica for partition DC=ForestDnsZones,DC=example,DC=local.
    Adprep encountered an LDAP error.
    Error code: 0x0. Server extended error code: 0x0, Server error message: (null).
    Adprep failed the operation on partition DC=ForestDnsZones,DC=example,DC=local. Skipping to next partition.

    If I try to connect to “DC=ForestDNSZones,DC=example,DC=local” using ADSI Edit I get the error:
    A referral was returned from the server

    If I attempt to run “cscript fixfsmo.vbs DC=ForestDnsZones,DC=example,DC=local” based on support.microsoft.com/kb/949257 I get the error:
    fixfsmo.vbs(19, 5) (null): The specified domain either does not exist or could not be contacted.

    If I run the command:
    ldifde -f Infra_ForestDNZSones.ldf -d “CN=Infrastructure,DC=ForestDnsZones,DC=example,DC=local” -l fsmoroleowner
    I Get:
    Connecting to “dc1.example.local”
    Logging in as current user using SSPI
    Exporting directory to file Infra_ForestDNZSones.ldf
    Searching for entries…
    Writing out entriesldap://ForestDnsZones.example.local/CN=Infrastructure,DC=ForestDnsZones,DC=example,DC=local
    No Entries found
    The command has completed successfully

    In DNS I do not see a folder for ForestDNSZones and I am unable to create this partition as “The specified directory partition already exists”

    In ADSI Edit in “CN=Configuration,CN=Partitions” I see a crossRef named “DC=ForestDnsZones,DC=example,DC=local”

    I have only 1 simple domain, no child domains.
    My current forest/domain functional levels are Server 2003
    My replication scopes are set to “To all DNS servers in the Active Directory DOMAIN example.local”

    Is the ForestDnsZone completely lost? Just a reference to it but not actually there?
    Should I change the DNS type to be just Primary / not intergrated, delete the Domain/Forest DNS zones and start again?

    I don’t know much about AD partitions but have tried the options above with no success.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.