2008 DC not starting…

Home Forums Server Operating Systems Windows Server 2008 / 2008 R2 2008 DC not starting…

Viewing 1 post (of 1 total)
  • Author
    Posts
  • Avatar
    Alyred
    Member
    #144936

    Hi all… I’ve been doing some research for a few days but I’ve not had any luck. I’ve never had to go to a tech forum like this in the past so hopefully someone will have some constructive advice for me.

    My 2008 x64 domain controller w/Exchange server 2007 was happily humming along, when all of a sudden it stopped responding, a total lockup. I waited a while and pressed the power button, hoping to have it reboot — but it then just continually waited at the logo screen, the green bar floating across it. I gave it all night, but it got no further. So I started digging.

    From the recovery console, I was unable to get any luck with the startrep command, said it couldn’t repair it due to a damaged registry. So, I went and found the registry backups in c:windowssystem32configregbackup. I backed up the original files and put these in place, and still wasn’t able to boot (startrep still couldn’t fix anything, but now gave a more cryptic error — something like “I don’t know what’s wrong”). I ran SFC which did find some problems, I had it repair, and it still won’t boot. Now, it gets past the logo screen but freezes shortly afterwards — seemingly randomly, but before I get to a login screen. Strangely enough, Active Directory recovery mode runs fine, and I used the backups created by Volume Shadow Copy to restore the registry to a few weeks ago. Still no luck, locks up in random places. AD recovery mode still runs fine, so I think it’s a startup service — but can’t find which one it is.

    Startup logging records different “lengths”, where the log just ends after different files. I don’t see a consistency there. I’ve replaced the video card, updated video drivers, and system mainboard drivers from the AD recovery mode. DNS (and I’m guessing other AD-related services) cannot start in AD recovery mode, so I can’t log in with a domain account to get access to recover my entire windows directory from Shadow Copy (it’s there, but when I try it gives an error that I need administrator access to restore (copy) some of the files to a new folder).

    Can anyone tell me how to get domain administrator access in recovery mode, log on as a domain admin, find out which service is causing a freeze at startup, or if all else fails, back up my AD schema and data including group policies, exchange settings/databases, and then restore it to a new installation? I don’t mind doing the work and some research, but google’s been pretty useless due to the garbage/info ratio and haven’t gotten lucky yet on there. Pointing me in the right direction would be greatly appreciated.

    Thanks for any help provided.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.