2003 Terminal Server RDP corruption

Home Forums Server Operating Systems Windows Server 2000 / 2003 / 2003 R2 2003 Terminal Server RDP corruption

Viewing 1 post (of 1 total)
  • Author
  • Avatar


    I have a few Terminal Servers which for the past 2 weeks have been blocking RDP access. This seems to occur after a Scheduled restart.

    We don’t know what’s happened and there are no Event Logs to give us any lead way. These servers have been converted to Virtual Machines (PTV) a while back and the most recent changes which we can find was over a month ago and that was UPHCLEAN install. I don’t think this could possibly corrupt RDP-tcp.

    By corruption, what I mean is that when I access tscc.msc, RDP-TCP connection, When I try and view the Network Adapter is just freezes. I have to end task for tscc.msc to close. Can’t see the adapter.

    Tried uninstalling and reinstalling adapter driver to no avail.
    We have tried disabling IPSEC (We have no policies anyway), checked the TDTCP driver is working and started.
    Checked registry to make sure its using the correct Network adaptor etc.
    All services are started etc. Restart of Server fails as well.
    Checked port 3389 and is not in use at all by any other applications.

    To resolve what I did was to delete the RDP-tcp connection, restart server, recreate the RDP-tcp connection, restart server again and RDP starts working. For now, until next week I guess.

    The RDP-tcp connection uses LOW Encryption if that makes any difference.

    I’d like to know what other things I can check or try. Windows Updates, terminal services repair etc. Any ideas?

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.